darktable unter Debian 10 aka Buster

Gespeichert von rsaalmueller am Sa, 2019-07-13 - 15:47

Debian 10 aka Buster bietet in den apt Sourcen ja nur die veraltete darktable Version 2.6.0-1 an. Wer den vollen Umfang von darktable möchte, ist auf andere Repositories angewiesen, oder baut darktable aus den Sourcen.

Da stellt sich die Frage bei jedem neuen OS und Release: Welche Pakete brauch ich denn?

Neben

apt install build-essential

habe ich mit dem folgenden apt Befehl, die anderen, notwendigen Abhängigkeiten installiert, um ein komplettes darktable mit allem drum und dran unter Debian 10 aka Buster zu kompilieren.

apt install git cmake cmake-extras intltool llvm llvm-dev clang python3-jsonschema xsltproc libsqlite3-0 libsqlite3-dev libjpeg62-turbo libjpeg62-turbo-dev libpng16-16 libpng-tools libpng-dev libpugixml1v5 libpugixml-dev libgtk-3-0 libgtk-3-dev icc-profiles liblcms2-2 liblcms2-dev liblcms2-utils exiv2 libexiv2-14 libexiv2-dev extract libtiff-dev libtiff-opengl libtiff5 libtiff5-dev curl libcurl4 libcurl4-gnutls-dev gphoto2 libgphoto2-dev libdbus-glib2.0-cil libdbus-glib2.0-cil-dev fop openexr libopenexr-dev libopenexr23 libsoup2.4-1 libsoup2.4-dev webp libwebp6 libwebp-dev liblensfun1 liblensfun-dev liblensfun-bin librsvg2-2 librsvg2-dev libjson-glib-1.0-0 libjson-glib-dev libcolord-dev colord libflickcurl0 libflickcurl-dev libopenjp2-7 libopenjp2-7-dev graphicsmagick libgraphicsmagick1-dev libgraphicsmagick-q16-3 libsecret-1-0 libsecret-1-dev lua5.3 liblua5.3-0 liblua5.3-dev libcups2-dev libosmgpsmap-1.0-1 libosmgpsmap-1.0-dev libcolord-gtk1 libcolord-gtk-dev po4a ocl-icd-dev ocl-icd-libopencl1 ocl-icd-opencl-dev mesa-opencl-icd

Es ist vielleicht das eine oder andere Paket zu viel dabei. Eventuell sind auch die "mesa" Pakete für Sie falsch, falls ihr OpenCL von proprietären Treibern geliefert wird. Für mich funktioniert es mit den Paketen und der Anleitung aus https://www.darktable.org/install/:

$ mkdir build && cd build/
$ cmake -DCMAKE_BUILD_TYPE=Release ..
$ make -j5
$ sudo make install